Mail server issue
Incident Report for
Surftown
Resolved
This incident has been resolved.
Posted
Nov
12
,
2019
-
13:32
CET
Investigating
Due to an issue on our mailservers, mails delivered to the server may be delayed or unavailable at this moment. Our technicians are working on a solution. Emails sent to the server will be queued and delivered later today.
Posted
Nov
12
,
2019
-
13:20
CET
This incident affected: Mail services.
×
Subscribe to Incident
Subscribe to updates for
Mail server issue
via .