Issues with phone lines
Incident Report for Surftown
Resolved
The issue has been resolved, and customer service and phone support are now available again.
Posted Jan 17, 2020 - 10:44 CET
Identified
Our telecoms provider are currently experiencing issues, and we are therefore unable to provide customer service or technical support for Swedish customers.

Swedish customers are encouraged to contact us through the chat on surftown.com until the issue has been resolved.
Posted Jan 17, 2020 - 09:53 CET